Unable to upload Elementor Pro

Hello, I have a WordPress site and use Cloudflare’s free plan which is currently enough for my needs. I have uploaded Elementor but I need Elementor Pro which I am unable to upload. I wonder whether this is because I need to upgrade my Cloudflare account? Any advice would be gratefully welcomed. Thank you in advance. Kim

absolutely not.

I use elementor pro and free Cloudflare plan for my clients. So far everything is running smoothly.

What kind of error did you get?

try increasing your wordpress memory limit.

1 Like

Thank you for your message. I believe it was regarding storage however I can’t remember exactly now as it was a while ago I tried. I have just tried to upload the plug in again but can’t work out what part of the zip file to upload. It doesn’t appear to let me upload the whole file. Argh!

What browser are you using?

I was using Safari! Thanks for this, I have followed the instructions and changed me settings to uncheck Open “safe” files after downloading but it’s still not letting me upload the whole zip file…

I just restarted my computer and browsers but no joy


. This is what I see when I go to upload…

have you tried uploading the zip file via ftp or hosting panel (file manager)?

to the /wp-content/plugins/ folder

I’m afraid I don’t know what either of these things mean. Sorry! Could you please explain.

I found an article that you might be able to apply

1 Like

Greetings,

Thank you for asking.

May I ask what error do you get? :thinking:
Can you share a screenshot of it?

How large the file size is (I guess zip file)?

Where from did you downloaded this “pro” plugin? Is it a nulled one or purchased?

I’d suggest you to try out suggestions as @keizha stated → upload directly the directory and files into /wp-content/plugins/ via FTP.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.