Unable to Update SSL Cert

I have site on Cloudflare which is currently using a custom SSL cert (set to expire soon).

I’d like to switch to using free, auto-renewing Let’s Encrypt cert. I’ve already set up the cert on my origin server (through WPEngine), but Cloudflare is continuing to show the custom certificate (which makes sense given that the custom certificate is still active and loaded).

From looking at other community posts, I believe I can use the Let’s Encrypt on origin and Cloudflare’s Universal SSL for Cloudflare.

When I attempt to enable Universal SSL, however, I receive the following error:

SSL has been disabled for this zone (Code: 1006)

Any thoughts

Are you talking about the proxy or the origin certificate? The former expires next Tuesday, the latter only next year.

Hey, Sandro.

I’m talking about the proxy which is expiring next week (the custom certificate which I currently see being served from Cloudflare).

All right, you do not seem to have a standard Cloudflare setup but rather some CNAME setup. Do you have a partner integration or a proper CNAME setup?

The latter, I believe.

Within WPE there’s a CNAME recored pointing to Cloudflare. And within Cloudflare, there’s a CNAME record showing it’s being proxied.

Any ideas @sandro? (or anyone else for that matter :slight_smile: )

On the Dashboard, what SSL Mode is set?


Hey, Michael.

It’s set to “Full(Strict)”. I dropped it down to “Full”, but was still unable to enable Universal SSL.

So…you’re using WPEngine, but your CNAME points to clio.com?

Does Clio belong to you? It’s not using Cloudflare name servers.

Hey, @sdayman.

Yes and yes :slight_smile: Clio is owned by me (or rather the company I work for) and you are also correct that we are not using Cloudflare’s name servers.

Ok. So if Clio isn’t using Cloudflare at all, I don’t see how Cloudlfare can issue a new certificate.

Well don’t I feel silly :slight_smile:

You’re absolutely right. Thanks @sdayman .

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.