Unable to turn off HTTPS for subdomain

Hi Everyone, new to Cloudfare here and having some issues with https/http.

We have Edge certificates for *.domain.com and domain. com
“Always use HTTPS” is turned on under “Edge Certificates”

We have a subdomain chat.domain. com that we created for our chat feature which uses web sockets. The issue is that to use the web sockets we need to access chat.domain. com through http not https.

We have tried applying various page rules to chat.domain. com including “Disable Security”, “Security Level = Essentially Off”, and “SSL = Off” as well as combinations of these rules.

Unfortunately the subdomain chat.domain. com either still loads with https or the page fails to load with a “too many redirects” error.

Any advice would be gratefully received as we’ve been trying to resolve this for a couple of weeks now.

Many thanks in advance!

(Please ignore the spaces between the “.” and the “com” in the URLs, I added those because the forum was reading them as links and wouldn’t allow me to post more than 2)

You need to disable Always Use HTTPS for your zone (domain) in the SSL/TLS section, and enable it for the main domain in a Page Rule. Kind of the opposite of what you’re doing right now.

Thank you so much! this worked!!

Ideally we’d have liked to do it the other way around but this is good enough for now.

Thanks again!

1 Like

This topic was automatically closed after 31 days. New replies are no longer allowed.