Unable to specify port for my IP redirection under A option

my ISP blocks most of the ports and among several open ports, my site is running at one of the posrt from 8081 to 8085.
I am unable to specify the port in the A section.
I tried looking for compatible and allowed ports like 8880 but still not working.

Regarding your ISP port blockage, I am sorry to hear that.

These ports are not compatible ones with Cloudflare, meaning hostnames (DNS records) that are proxied (:orange: cloud) would not work.

Kindly, see below article which ports are supported and compatible with Cloudflare, and do configure your app to use the right one:

Furthermore, you can use some kind of a load balancer, for example for home network the “Kemp”, with which you can use different ports for different apps locally, but to the outside Internet it can be configured to use the single one and supported port by Cloudflare like 443.

Meaning, your apps from the outside can be accessed by the same port.

Example of a Kemp setup for home and a custom domain running behind Cloudflare, all on the same port 443, see here:

You can’t add port numbers to “A” records. Only the IP address.

It would work much better to set up a Cloudflare Tunnel.

https://developers.cloudflare.com/cloudflare-one/connections/connect-apps

1 Like

Thanks.
I thought this would be my solution.
Tutorial is a bit tough. Still will keep trying and post update as It might help others too.
Really necessary to run multiple sites on same IP using cloudlare.

8880 is already include in compatible port list.
Further APACHE is managing multiple apps on different ports.
Currently forwarded 80 incoming port to 8880 using router but it is just temporary solution.
The solution will not work while running multiple sites on same IP.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.