Unable to setup ssl certificate on my website

I am trying to enable ssl certificate on my site.I have changed the name servers as instructed by Cloudflare on my domain provider site and also installed Cloudflare plugin in my wordpess but still the https is not appearing.

Enable? How? Did you configure a certificate on your server?

I get a domain from freenom.com and after that i bought a hosting which was not providing SSL certificate.For that,i came to cloud flare where they asked me to enter my website name.after that they provided me two server names and asked me to copy that server names in my domain server names.I then opened my wordpress and also installed Cloudflare SSL plugin and then i turn on the HTTPS from cloud flare for my website.But still my website is insecure?

Then you need hosting which provides SSL. Cloudflare alone wont secure your website. As long as you dont have a proper SSL setup on your server your site will be insecure.

doesn’t it work for free hostings?

Free or paid does not matter. Your server needs to support SSL. If it doesnt your site cant be secure by definition.

how can then i make my server support SSL?Kindly assist.

You need to contact your host.

Thank you very much sandro.

I get a domain from freenom.com and after that i bought a hosting which was not providing SSL certificate.For that,i came to cloud flare where they asked me to enter my website name.after that they provided me two server names and asked me to copy that server names in my domain server names.I then opened my wordpress and also installed Cloudflare SSL plugin and then i turn on the HTTPS from cloud flare for my website.But still my website is insecure?

This topic was automatically closed after 30 days. New replies are no longer allowed.