Unable to save WordPress website when Cloudflare is enabled. Getting 520 Server response errors

We are using WordPress and all of a sudden I am unable to save pages when Cloudflare caching is enabled on the website. I get 520 server response errors when loading the /wp-admin/ajax.php file.Screen Shot 2020-09-10 at 6.04.46 PM|690x6

I am using the Divi theme. We have tested the website without any customizations and with plugins turned off. It didn’t solve the problem.

Has anyone else had a similar issue with Cloudflare and WordPress?

Did you read this post?

Also, would you happen to have Rocket Loader enabled from Speed -> Optimization? I don’t expect that to be the problem, but it’s a variable to remove.

1 Like

Hi there,

Does this issue reproduce using our recommended settings for Wordpress?

Disabling Cloudflare features on admin pages for content management systems like WordPress – Cloudflare Help Center

Let me know if it resolves the issue.

  • Gabe
1 Like

Hi all,
The topic is also being discussed here: Random 520 error
I’m using the page rules suggested, but doesn’t make any difference. I wasn’t using them since three days ago. Didn’t need to.
What I’ve noticed is that the 520 errors occur even if you navigate on the frontend of the site but only if you are logged in. Navigating as a regular visitor has no issues at all.


I have a similar issue. I have been using Divi with Cloudflare for over 2 years then 2 days ago just out of the blue, this happened. When I save a post or page that has a little bit of content its fine. When the content goes past a certain size all of the content is then deleted and returns me a blank page. I am using a development site for my live site which is not cached. When I turn Cloudflare off the problem is gone. Have looked at the options above but as I’m not catching it anyway the rule is not needed. Any ideas would be appreciated.

1 Like

You can check my reply Random 520 error. Maybe it’ll help some cases.

This topic was automatically closed after 31 days. New replies are no longer allowed.