Unable to retrieve logpush logs, getting 524

I’m using postman to retrieve my workers logs configured with logpush (R2).

It used to work up until last week, right now I’m consistently getting 524 even on 5 min log range:

GET https://api.cloudflare.com/client/v4/accounts/{{cf_account_id}}/logs/retrieve?bucket=logpush&start=2024-02-07T22:35:00Z&end=2024-02-07T22:40:00Z

Status: 524

<!DOCTYPE html>
...
<title>api-gateway.api.cloudflare.com | 524: A timeout occurred</title>
...
<span class="inline-block">A timeout occurred</span>
<span class="code-label">Error code 524</span>
....

Hi @john.webb.miller Have you tried pushing even smaller increments to see if this problem still occurs? We had several incidents yesterday, so it would also help if you could try again today, and let us know if the problem persists.

I just tried it again:
GET https://api.cloudflare.com/client/v4/accounts/{{cf_account_id}}/logs/retrieve?bucket=logpush&start=2024-02-07T22:35:00Z&end=2024-02-07T22:45:00Z
Got 503

 <title>Worker exceeded resource limits | logs.cloudflare.com | Cloudflare</title>

@jochen are you guys planning to fix it? I’m still getting 503 :frowning: