Unable to resolve: vmlabblog.com

I am unable to resolve: vmlabblog.com using 1.1.1.1 but can resolve it just fine with other DNS servers.

I seem to have been having these strange resolution problems lately…

Have problems with 1.1.1.1? Read Me First - DNS & Network / 1.1.1.1 - Cloudflare Community

I tested, I can resolve the domain using 1.1.1.1/1.0.0.1 and 1.1.1.3/1.0.0.3. No issues.

dig vmlabblog.com @1.1.1.1

; <<>> DiG 9.10.6 <<>> vmlabblog.com @1.1.1.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 22942
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
; OPT=15: 00 16 ("…")
;; QUESTION SECTION:
;vmlabblog.com. IN A

;; Query time: 1970 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Sat Mar 27 08:37:02 PDT 2021
;; MSG SIZE rcvd: 48

dig vmlabblog.com @1.0.0.1

; <<>> DiG 9.10.6 <<>> vmlabblog.com @1.0.0.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 46724
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
; OPT=15: 00 16 ("…")
;; QUESTION SECTION:
;vmlabblog.com. IN A

;; Query time: 1975 msec
;; SERVER: 1.0.0.1#53(1.0.0.1)
;; WHEN: Sat Mar 27 08:37:13 PDT 2021
;; MSG SIZE rcvd: 48

dig vmlabblog.com @8.8.8.8

; <<>> DiG 9.10.6 <<>> vmlabblog.com @8.8.8.8
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 15605
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;vmlabblog.com. IN A

;; ANSWER SECTION:
vmlabblog.com. 14399 IN A 185.182.57.125

;; Query time: 416 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Sat Mar 27 08:37:24 PDT 2021
;; MSG SIZE rcvd: 58

dig +short CHAOS TXT id.server @1.1.1.1
“LAX”

dig +short CHAOS TXT id.server @1.0.0.1
“LAX”