Unable to resolve on root domain despite creating A record and setting up a 301 redirect

Hi there,

I hope someone can help. I’m trying to set up a rule so that I can get SSL on my root domain (as my web host doesn’t provide this). I’ve connected the domain fine - see this link here.

I’ve tried to add an A record

Create a redirect rule
And a page rule

But none of those seem to work and the root domain will not load.

ANy suggestions on what I’ve done wrong / what else I should try?

Here are some more screenshots

Creating forwarding

Creating Page Rule

Page showing when attempting at root domain https://oliver-wells.co.uk

This is the page that I see, you may be using cached DNS records:

Also redirects only work for proxied records, not when set to DNS-only.

1 Like

Thanks for your reply Laudian.

To confirm I’m talking about what I see when I try to access https://oliver-wells.co.uk/ (as https://www.oliver-wells.co.uk/ is working fine). When I try to access it without the www it’s not working for me and I’ve tried on some other devices without the caching. Can you confirm if you’re able to get it to properly load at https://oliver-wells.co.uk/?

Good to know about the a record though so I’ve turned that on to proxied.

Any other suggestions?

Now you have turned that on, Cloudflare does the redirect you set up. As @Laudian mentioned, without it the request never goes through Cloudflare so it can’t redirect for you. It is now working.

curl -I https://oliver-wells.co.uk/
HTTP/2 301
date: Wed, 22 Nov 2023 13:53:21 GMT
location: https://www.oliver-wells.co.uk
1 Like

Thanks SJR. That’s good to know, the reason I changed it is I originally had it set up like that but it wasn’t working.

I’m still getting the error when I try (even with non cached browsers), but is that a propogation thing and it will resolve in due course?

Just confirming the redirection works fine from my end as well.

So the problem is just at your end.

Thank you all - this is indeed resolved. Appreciate you all.

1 Like

For future reference - the key element was I had:

  1. Created an A record but set it to DNS-Only (it needs to be proxied)
  2. THere was some cache on my router meaning any visit via my home internet connection would show the cached (not working page)
1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.