Unable to resolve kuaikanmanhua.com


#1

(output sightly edited because I can’t post more than two links)

dig kuaikanmanhua .com @ 1.1.1.1

; <<>> DiG 9.10.3-P4-Ubuntu <<>> kuaikanmanhua .com @ 1.1.1.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 58935
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1452
;; QUESTION SECTION:
;kuaikanmanhua .com. IN A

;; Query time: 4343 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Sat Jun 16 19:47:45 CEST 2018
;; MSG SIZE rcvd: 46

dig kuaikanmanhua .com @ 8.8.8.8

; <<>> DiG 9.10.3-P4-Ubuntu <<>> kuaikanmanhua .com @ 8.8.8.8
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17351
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;kuaikanmanhua .com. IN A

;; ANSWER SECTION:
kuaikanmanhua .com. 89 IN A 106.75.64.45

;; Query time: 346 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Sat Jun 16 19:48:50 CEST 2018
;; MSG SIZE rcvd: 62

dig +short CHAOS TXT id.server @1.1.1.1
“cdg01”

dig +short CHAOS TXT id.server @1.0.0.1
“cdg01”


#2

Thanks, it’s a known problem with dns.com nameservers (they strip EDNS and don’t support letter case randomization). The override didn’t cover all their NS names, so I fixed it by adding v1.dns.com and v2.dns.com to the list. It should work again, sorry!