Unable to resolve IP address correctly

My domain name is soslane.top. Regardless of the A record I add, it always resolves to the same IP address when Cloudflare proxy is not enabled. How can I solve this problem? I also created a new worker and a custom domain b.soslane.top, which still resolves to I have tried clearing the DNS cache, but it doesn’t work.

b.soslane.top resolves to a Cloudflare IP address for me so seems to be proxied (soslane.top doesn’t seem to have a DNS record set)…

Can you show a screenshot of your DNS records?

Also, check what DNS resolver are you using on your device. It may be that is returning another IP address for your domain for reasons local to you.

Also check your SSL/TLS setting is set to “Full (strict)” here…

1 Like

Your SSL/TLS setting should be set to “Full (strict)”, but that’s not your issue.

Your record isn’t proxied now, so I can see your direct IP address not a Cloudflare one…

The resolver you are using is returning a different IP address for reasons likely due to your ISP/country policies. There is no problem with your Cloudflare settings.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.