Unable to resolve CNAME record even though it exists

I recently set up a new Wordpress website on my VPS called bestteacherresources.com. I’ve installed the Cloudflare plugin and set the new domain up in Cloudflare. Everything was working perfectly fine - including email delivery.

For reasons unknown, as of yesterday, I can no longer resolve the CNAME record for mail.bestteacherresources.com:

nslookup [the domain name here]


** server can’t find [the domain name here]: NXDOMAIN

As a result, I cannot ping [mail. the domain name here] and my mail clients can no longer connect, meaning that email delivery has stopped working. Curiously, I sent an email to an address on this domain before I went to bed last night. Even though the mail client was not connecting at the time, when I woke up this morning, that message had actually been delivered. This suggests to me that the name resolution might have worked very briefly at some point but then stopped again. At the time of this writing, I can still not resolve [mail. the domain name here].

From what I can tell, the CNAME record exists in the Cloudflare DNS configuration:

CNAME mail| [the domain name here] Auto Proxied

I’ve compared the configuration (Wordpress, my own VPS DNS zones, Cloudflare DNS configurations) between my various domainnames on this same VPS and I can find no differences between them. They each have similar DNS records all setup, so this domain should be working just like all the others I have.

I used mxtoolbox to check the DNS records and it is also reporting that there is no CNAME record for [mail. the domain name here] even though I can see it in my Cloudflare configuration.

My Wordpress version is 5.6 and the Cloudflare plugin version is 3.8.7.

Any suggestions for why the CNAME record is not showing up to the outside world when it appears to be present in the Cloudflare DNS configuration for my domain?

For reasons still unknown, the DNS resolving has suddenly started working again. However, although the mail service is running on my VPS, no mail clients can yet connect to the service. Not sure if this is some sort of propagation issue on Cloudflare’s end of something like that?

Your mail subdomain is set to :orange:. It should be :grey:.

1 Like

Oh, I hadn’t spotted that. That fixed the problem. Thanks! :slight_smile:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.