Unable to redirect from http to https

https

#1

As per the documentation of cloudflare i made the below changes

  1. In the crypto section added the check of "Always use HTTPS "
  2. In the page rules section, enabled “Always use HTTPS”
  3. added the name servers in the GO DADDY

The output we are getting is it not redirecting to https URL but just moving to http address

FYI
The web application(Flask) is running in digital ocean with the url (http://xx.xx.xx.xx:2053/admin/login)

Pls suggest

Thanks
vij


#2

Hmmmm…I’m thinking Always Use HTTPS is only checking Port 80 requests.

One approach would be to add a subdomain, like admin.example.com, then create a Page Rule that redirects http://admin.example.dom/* to https://example.com:2053/admin/login

I’ve not tried this, but it would be my first approach.

Some admin panels have a config option to force SSL.


#3

This topic was automatically closed after 14 days. New replies are no longer allowed.