Unable to receive new emails and login IMAP

Hello, I am new to cloudflare and I am trying to setup a new domain. I have added all the DNS records but I am unable to receive new emails or add the email account as IMAP to mac mail.

I can still access webmail and send emails but just cant receive any or add it as an IMAP account as mentioned

I have tried replicating some topics similar to my issue but have had no success, I have attached an image to show my current DNS settings, Any help would be appreciated!

For your CNAMEs you need to include the domain in the content (but not the name field).

So CNAME imap mail should be CNAME imap mail.devwork.co.za, etc.

1 Like

Hey Sjr thanks for the fast response I appreciate the help, I have changed the records and I am able to log into the email via my mac mail, however when I try to send a test email I get this response:
This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

[[email protected]]
all relevant MX records point to non-existent hosts
Reporting-MTA: dns; [antispam6-jnb1.host-h.net]

Action: failed
Final-Recipient: rfc822;[[email protected]]
Status: 5.0.0

Do I need to change my MX records content field to also be mail.devwork.co.za? and this might be a dumb question but should I do the same for the FTP CNAME record? Thanks for the help!

Yes.

If you use FTP then yes. If you don’t, then you can delete that record.

1 Like

Thanks for the help sjr, I was able to get it working with your recommendations!

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.