Unable to purchase in ZeroTrust

Chose the plan and purchase button does nothing.
tried different credit card and paypal.
in chrome console it gives 402 payment required.

Access β†’ applications is blocked for not selecting a plan. how to fix it?

2 Likes

You should make a billing ticket here: https://dash.cloudflare.com/?to=/:account/support

Same issue here. Have tried multiple payment methods, multiple browsers, multiple devices and multiple different internet connections over the course of 2 days now and still can’t purchase a Zero Trust plan - clicking the purchase button just does nothing. I have a support ticket #3115543 but no updates as yet.

1 Like

I have the same issue. I opened at support ticket #3119357 yesterday and it was marked solved with no explanation. The issue still isn’t resolved so I opened another one, #3119989

1 Like

Same issue here.

1 Like

A fix has been deployed by our team. You should be able to accomplish this now.If not please let us know.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.