Unable to preview your Worker. No matching Zone on your account found

I have just deployed a worked with this rule:

routes = [
    { pattern = "www.mydomain.com/*", zone_id = "my-zone-id" }
]

I copied the zone id from the website page for mydomain.com.

The worker doesn’t respond, I have logs for each request and there comes nothing. When I click on Quick edit for that worker, I get a message

Unable to preview your Worker on https://www.mydomain.com/ . No matching Zone on your account found.

It’s quite weird as I just copied the zone id from the website page, and it’s the same account. I tried using zone name, I tried to delete the route and adding it via the UI, selected the zone there (I can’t just type the zone there, I choose one from the list), and the result is still the same.

Any idea what the problem could be? I have another account with a similar worker and there it works fine.

1 Like

Hello!

Sorry to hear you’re having trouble with Worker Previews.

I believe it’s related to this current incident:

If it doesn’t clear up once the incident is resolved, please let us know the actual hostname, and we’ll take another look.