Unable to post a comment with attachment

I disabled Cloudflare by disabling the proxy, after this the issue is gone. It can not be an origin problem in my opinion since many people have the same issue since a month.

I was finally able to do some thorough testing.

  1. When I disable the Cloudflare proxy on my site, I am able to upload files, even big ones.
  2. When I enable Cloudflare, I can upload small files, but not large ones. 50kB is ok but 100kB is rejected.
    I have added this information to my ticket. Now waiting to see what Cloudflare support has to say.
    Can someone confirm that they also see this behaviour?
1 Like

Thanks a lot for taking the time to gather this information!

This blockage of image uploads is a serious issue that probably affects many, if not all, WordPress installs, so I hope it gets the attention it deserves.

@frank5 I had exact the same behaviour.

It’s been two weeks now. I’d be curious to know if the CloudFlare team has been able to pinpoint the issue following your request #1741534?

They asked me for more information, so I assume they are working on it.

1 Like

Hello, everyone.

Would love to get an update about this issue as well.
From what I see it looks like a few upload-plugins are no longer supported by their developers. For now we are planning to de-activate the current upload-plugin just to solve the issue.

But in the long run we will of course need a new solution for comment uploads or advice users to only share links to their social profiles.

Thanks for your update. Please make sure to keep us posted :wink:

This topic was automatically closed after 30 days. New replies are no longer allowed.

Hi everyone,
I’m a WordPress developer and one of my plugin allows customers to include photos in their reviews of a WooCommerce product. The problem is that Cloudflare blocks all reviews if customers attach images in their reviews and this prevent our plugin from working correctly.

I’ve been following this topic https://community.cloudflare.com/t/sorry-you-have-been-blocked-firewall-is-off-but-still-blocking-wordpress-comments/ for a while and a man from Cloudflare team says that “You could try a page rule to disable WAF completely for that URL, on a paid plan you could also disable that specific rule I believe.” i see from this is that you can only change this if you use a paid plan. What’s about people who use a free plan? That topic was closed without clarifying this.

So what i want to know is that: is there any way free plan users can do so that their customers are not blocked when they leave reviews with photos.

Thank you and best regards.
Kim

Hi @kim2,

Please have a look at this topic where it was discussed in more details with information from Cloudflare Support:

Thank you @domjh,
Frankly, i had been following that topic, too. But as you can see that topic was closed on Sep 17th without any specific answer that everyone need. That’s why i create this new one hoping that i can find a solution for this from the side of an developer.

The topic had the only answer that we have! Unfortunately, we don’t have any more insight into that than was posted there.

The advice I was given by support is in line with this post from @floripare:

Perhaps someone else here can assist with this, but I’m afraid that is all the info I know!


Also, merging this thread with the other to keep all discussion on this issue together.

This topic will automatically close 7 days after this post.

I purchased a paid plan, disabled the specific WAF Block rule and it’s still blocking reviews being posted with photos (>~60kb) attached. I turned off WAF completely and even then, it’s still blocking me and any other user.

1 Like

What is the solution for free plan users other than disabling CloudFlare CDN?
Like what is the step by step solution for a noob like me?

This topic was automatically closed after 6 days. New replies are no longer allowed.