Unable to manage subscribed app #iubenda

Hi, I subscribed to the iubenda app and installed it, but the app isn’t showing up in the installed app section. I tried it three times, and it isn’t working. I can see the app in the Cloudflare subscriptions, and the payment status is ‘Paid’. In iubenda account, I can see three paid LICENSES & SUBSCRIPTIONS, because I tried it three times! What can I do?


Hello Chandu,

Thanks for standing by.

I have replied to your existing support ticket with more information in order to share information that should not be publicly posted in the Cloudflare Community.

Please correspond with Cloudflare Technical Support in that ticket moving forward.

Much appreciated!

Hi Chandu,

Thanks for your patience here.

Per https://www.cloudflare.com/apps/iubenda

Support contact
[email protected]

I am sorry to hear that you are experiencing some difficulties here, but unfortunately, the root issue involves a service not owned by Cloudflare. We recommend you to contact iubenda support team to troubleshoot further.

If you have any issues with Cloudflare products or services please don’t doubt reaching us again.


Alex M. he/him/his | Technical Support Engineer