Unable to login with SSL active

ssl

#1

Hi, I’m Sin.
Just signed up with Cloudflare for free SSL for a website that I created for my non-profit organization.
Unfortunately, I was unable to login to the website after the SSL was added. Any advice? Has anyone experienced a similar problem?
(The website was created using Wordpress.)


Welcome! Say hello!
#2

I’m assuming you mean that you can’t login to the wordrpess admin, and NOT your Cloudflare account. There are a variety of configuration options that you should look into if you are using Cloudflare with a WordPress site, most notably the Cloudflare WordPress plugin. This article has some helpful information.


#3

Yes, I am unable to login to the wordpress admin. Thanks for the link to the article but my present need is to resolve the issue of being unable to login. Any suggestion to this end?


#4

I suspect that the problem was because I activated a plugin called Really Simple SSL and left it activated when I logged out while the SSL from Cloudflare was not in place as yet. So when the SSL was in placed, the active plugin prevented my logging back in. If so, how do I get Cloudfare to temporarily disable the SSL so that hopefully, the plugin will allow me to login in to the admin page again?


#5

You can “deactivate” that plugin by FTPing in and deleting it from the wp-content/plugins directory.

Another approach would be to :grey: the DNS entry and connect directly.


#6

There are also specific Page Rules that are recommended for your login and admin pages if you are using Wordpress. Have a look at this video, taking notice of the rules recommended at about the 2:50 mark.


#7

It is really unfortunate for me that you really have no idea as to my problem. I am UNABLE to get to the admin page of my website. I need to resolve that first. How do your suggestions so far enable to do just that?

If you have no solutions, please don’t add further to my existing aggravation.


#8

Sorry. Not trying to frustrate you. It’s important to set page rules specific for your admin pages. Since you don’t want those cached the same way.

Have you tried adjusting the SSL settings on Cloudflare? Or @sdayman’s suggestion to ftp?


#9

It is okay. I just managed to get back into the admin page by bypassing Cloudflare, change certain security settings, reactivate the Cloudflare DNS and reactivated the Really Simple SSL. The website is now working fine.


#10

My apologies to you and Ryan. I was so stressed that I did not see your suggestion earlier. I eventually figured out your second suggestion and that enabled me to get back into the admin page. The root of my problem was a setting in a security plugin that prevented the SSL plugin to do its job properly when I logged out while the SSL plugin was in active mode and when the Cloudflare SSL was subsequently in place. Thanks.


#11

No worries. Just glad to see that you have things working now.


#12

have you changed your website url to start with https ?


#13

Yes but the problem occurred because my security settings did not allow the Really Simple SSL plugin to do its job. That has been fixed now and the SSL is working just fine. Thanks.