Unable to login to application hosted on IIS using form based authentication

I have a windows 2012 running Solidworks PDM Web using form based authentication, if i go directly to the website by IP i can login without a problem, when i try to proxy through cloudflare and use the application access with authentication then the form based authentication does not allow me in and states the username and password are wrong.

The webserver itself is behind an Nginx reverse proxy at the site and works through it without a problem going direct, just not through cloudflare.

@MoreHelp

By any chance, do any of the URLS for your website contain ports that are not compatible with Cloudflare proxy? Here’s a list of compatible ports:

Thanks put just 80 and 443 http/https so no other ports are used, if i go directly to the site its fine, just doesnt work through cloudflare

Thanks put just 80 and 443 http/https so no other ports are used, if i go directly to the site its fine, just doesnt work through cloudflare

What about SSL tab/settings page at Cloudflare for your domain and your host/origin?
Do you have an SSL certificate installed at your host/origin?

I assume, maybe you do not allow Cloudflare IP addresses to connect to your host/origin due to security or a network measurements?

What happens when you switch from :orange: to :grey: or temporarly Pause the Cloudflare for your domain?

Thanks for the help, if i pause the proxy it works fine, as for allowing cloudflare to access it, nothing has been setup and its a default windows IIS behind nginx (Nginx proxy manager) if that helps

A bit difficult to tell what the issue is without having additional context. I found your support ticket, and would be helpful if you could capture a HAR file demonstrating the issue when you proxy the site and send that back to the support ticket. That will allow us to see the requests and responses which may help determine where the issue is occurring.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.