Unable to log into dashboard or Zendesk

I have the same issue described here: Unable to log into Zendesk, but with some extra complications due to rate limiting.

I’ve tried different browsers, devices, etc. It’s most apparent with secondary administrators (rather the account owner), which always end up in an infinite loop. It happens with the account owner as well, although the cycle is eventually broken and I can get in. This has been an issue for months.

To make matters worse, I get a 429 error from cloudflare-lb if I attempt more than once, meaning that I’m completely locked out from logging into any account. The rate limit applies to at least four requests for each login attempt:

  1. Loading the login form
  2. Submitting the login form
  3. Loading the 2FA form
  4. Submitting the 2FA form

Even if I wait long enough to load the login form again, I often get blocked at once of the later request, resulting in cryptic error messages like “Please reload the page”–bad advice, given that the status for the error response is 429. This means I’m locked out of everything–not just Zendesk–for an indeterminate period of time, and any attempt to get back in could mean that it takes even longer.

The exact behavior is inconsistent. For example, at the moment, whenever I submit the form at https://dash.cloudflare.com/login now, even after clearing cookies, I receive the following page. It’s the same error that I sometimes see associated with a 429 ajax response, but in this case there’s no 429 in sight, just a 401 response:

I see an interesting request to https://dash.cloudflare.com/api/v4/captcha/challenge?context=login&email=... in the network log, but it’s return 200 with no content. There’s also a request to the same URL with no querystring, with a response of {"result":{"challenge_required":false,"key":"..."},"success":true,"errors":[],"messages":[]}.

Hi @Zenexer,

Are you still having issues logging in? If so, can you confirm if the issues remain in a private/incognito browsing window with all extensions disabled, or another clear browser? I am not having any issues on Chrome or Firefox.

3 Likes

It’s been happening for months on a variety of new devices and browsers. I just logged in to respond to you; if I try to log in again (e.g., to Zendesk), I can pretty much guarantee it’ll kick me out the first time, and the second time I’ll get rate limited. Let’s see!

  1. Logged into forums from business account on a recently-wiped Safari with all content blockers disabled. (@Zenexer is my personal account.) I was using Chrome yesterday.
  2. Went to dashboard
  3. Went to Help Center
  4. Clicked Sign In
  5. Entered username and password
  6. Entered TOTP code
  7. Selected account
  8. Was redirected to dashboard instead of Zendesk
  9. Repeated the process a second time
  10. Attempted to repeat the process a third time; received 429 error

This is easy to reproduce on an administrator to a Pro account—it happens every time. It happens to the owner account as well, but not every time, so as long as I get in before being rate limited, I can at least access Zendesk. However, I have multiple Cloudflare accounts that represent different organizations, plus my personal account, so I’m likely to be rate limited before I can get in, even with owner accounts. This is even more of an issue if I’ve been using the forums, since logging into the forums also counts against the rate limit; I almost always use my personal account on the forums, rather than multiple organization-specific accounts.

Confirming that @Paul-NP is me–specifically, it’s the account on which I’m always able to reproduce the issue. I can’t get into Zendesk from that account.