Unable to install WARP 1.4.x agent for Teams on my Windows device

My scenario:

  1. I have an installed WARP client before. However, i missed some steps and its not successfully connecting to my CF Access Gateway, so i decided to uninstall to refresh installation.
  2. I tried to uninstall via Windows App Add/Remove Programs. Uninstallation is not working. Even if uninstall completes, the application remains listed in Add/Remove Programs and in Program Files. I even can still run the apps. Tried multiple times uninstalling, but no luck.
  3. I tried manually removing all cloudflare WARP related files on my system (registry and everything from search result in drive C)
  4. I have confirmed all related files and registry entries are removed.
  5. Tried downloading new installer and install. During install progress bar, the error is:
    Cloudflare WARP setup Wizard ended prematurely because of an error. Your system has not been modified. To install this program at a later time, run Setup Wizard again. Click the Finish button to exit the Setup Wizard.
  6. There are error message in Event Viewer but not very informative.

Please advise if i missed anything that needs to be removed. Will appreciate advice.