Unable to install cloudflared on CentOS

I am getting the following error when I install cloudflared on my CentOS

# sudo yum install -y cloudflared.rpm
Loaded plugins: fastestmirror
Examining cloudflared.rpm: cloudflared-2022.7.1-1.x86_64
Marking cloudflared.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package cloudflared.x86_64 0:2022.7.1-1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved
 Package                                                            Arch                                                          Version                                                           

Repository                                                           Size
 cloudflared                                                        x86_64                                                        2022.7.1-1                                                        /cloudflared                                                         31 M

Transaction Summary
Install  1 Package

Total size: 31 M
Installed size: 31 M
Downloading packages:

Package cloudflared.rpm is not signed

#cat /etc/redhat-release
CentOS Linux release 7.9.2009 (Core)

Any guidance on what I can do to troubleshoot this further, and install cloudflared?

Opened a support chat with @Chris_M, and as per their suggestion, I tried previous assets! But same issue with 2022.6.3 and 2022.7.0

May I ask if the cloudflared repo is still existing or removed somehow? :thinking:

Regarding “is not signed”; have you tried re-adding a key again, just in case?

Have you used the signed one from https://pkg.cloudflare.com/, or rather unsigned from GitHub? :thinking:

I can find that there were some issues on GitHub repo as well.
have you tried writing an issue there too?

We solve the issue together.

This topic is now closed.