Unable to install cloudflare-warp package

deb [arch=amd64 signed-by=/usr/share/keyrings/cloudflare-warp-archive-keyring.gpg] https://pkg.cloudflareclient.com/ bullseye main

this is the output after do this command > cat /etc/apt/sources.list.d/cloudflare-client.list

this is the output after do this command > cat /etc/apt/sources.list.d/cloudflare-client.list

What is the error you are getting when doing sudo apt update?

I’m having the same issue with debian bookworm. When trying to install it just says “Unable to locate package cloudflare-warp” I’m guessing that the repository moved and documentation hasn’t been updated?

cat /etc/apt/sources.list.d/cloudflare-client.list deb [arch=amd64 signed-by=/usr/share/keyrings/cloudflare-warp-archive-keyring.gpg] https://pkg.cloudflareclient.com/ bookworm main

1 Like

the update run normally but , still cannot install cloudflare-warp (with the same error) > “Unable to locate package cloudflare-warp”

why like this sir when i register

1 Like

You need to edit the apt source file, as I don’t believe mantic is supported. Something like bookworm should work.

@sun.p @jeavis What is the output of sudo apt update and apt search cloudflare-warp


i do edited /etc/apt/sources.list - i do uncomment line below

the install cloudflare-warp not yet success @banbanbrosis

i do install with script warp.sh i get from github
the output :
[INFO] Installing Cloudflare WARP Client…
[ERROR] This CPU architecture is not supported: armv7l

so, what must i do sir? i newbie, i installed ubuntu 1 month ago

Given you are on a pi, if you have the arch=amd64 then remove it. Given the error message of the GitHub install script, it might me that warp isn’t supported on pis.

1 Like

Edit /etc/apt/sources.list.d/cloudflare-client.list and change mantic to bookworm.

you mean cloudflare-warp is not supported for raspberrypi ?

Correct. It might not be supported for armv7. Once you remove the arch=amd64 run sudo apt install cloudflare-warp.

I have removed the arch=amd64 but still not working…
Yes, I’m also on a pi.

It seems that only amd64 architecture is supported.