Unable to get "Redirect Rules" to work

I’m trying to create a redirect in the new Redirect Rules, but I am unable to make any of them work.
I have tried the basic examples in


Are there any obvious things that can be wrong if no rules work?

  • The domain is handled by Cloudflare and Proxy Status set to Proxied
  • In case it interferes, I have disabled the rules under Page Rules
  • It’s on Free plan for now, but there should be 20 redirect rules available

Could you please share a screenshot of the rule you created?

Thanks for responding, I actually need a geolocation redirect, but have made this very simple one to check if redirects work at all.

What is your domain?

It’s perhoj.no

When using your domain with a Cloudflare Partner (such as WPEngine in this case), you do not have control over the rules on your zone. The redirects will have to be created in WPEngine.


Wow, I was not aware of that. It’s not really communicated in the interface either.

Tested now, and found a menu in WPengine called “Web rules” that almost matched the settings in Cloudflare. I can do blocking on geolocation there, not redirect, but that will do for now.

Thanks for the hint! I might test to see if pointing Cloudflare to the “legacy network” in stead of the “advanced network” IP addresses on WPengine will enable the rules to work from Cloudflare.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.