Unable to force HTTP > HTTPS for subdomains

Hi All. Just joined this community and making my first post, so please be kind if I don’t do this perfectly. :hugs:

I have a main site and two subsites: greatalbum.net, app.greatalbum.net, help.greatalbum.net. I want all of them to auto redirect HTTP > HTTPS. I’ve followed directions at both of these resources:

  1. https://developers.cloudflare.com/ssl/edge-certificates/additional-options/always-use-https
  2. https://blog.cloudflare.com/how-to-make-your-site-https-only

It seems like I have the configurations correct:

But only the main site is forcing HTTPS. The subdomains are not.

I’ve searched and read several posts in this community, but none of them seems to answer my problem. Any ideas what I’m doing wrong?

app and help don’t appear to be :orange: for DNS so it is going direct to the Origin server and these settings require it be :orange: not :grey: .

1 Like

I found hot to change that.
Environment name → DNS. Proxy status column.

HI

Sorry where can I get to that setting please