Unable to enable Argo

Are you on a partner setup? This is usually through host.

Also, is this your account where you’re the super-admin, or are you added onto someone else’s Cloudflare account in a multi-user setup?

I used a partner to access my site, and this is my account, I am the administrator

If it’s a partner setup, it’s quite likely you won’t be able to enable that feature. Have you asked the partner your domain is connected to about this?

Thank you very much for your reply. I was able to use it properly about 6 months ago, was this a rule change?