Unable to enable Always Use HTTPS

I’ve read a lot of forum topics hving the same problem but could not find any solutions…
I have a domain with the Universal SSL on and full encryption mode.

but when i access http://room4me.com.br it does not redirect to https…

Can anyone help me find the problem?

It does so for me

$ curl -I http://room4me.com.br
HTTP/1.1 301 Moved Permanently
Date: Tue, 08 Oct 2019 19:01:46 GMT
Connection: keep-alive
Cache-Control: max-age=3600
Expires: Tue, 08 Oct 2019 20:01:46 GMT
Location: https://room4me.com.br/
Server: cloudflare

Though, your www record is not proxied, hence none of the Clouflare settings will take effect and it will only work on the naked domain.

1 Like

Sandro, Thank you for your reply…
shouldn’t it redirect also http://www.room4me.com.br?
image

Do i need to make explicit url redirects for it to work?
The thing isk, i have a cdn on azure working… https://c6-consulting-uni-prod01.azurewebsites.net working…
i want that every call that has room4me.com.br www or otherwise goes to that cdn…
When i call https:// www.room4me.com.br iit already goes correctly to my cdn…
Sorry the noob question :frowning:

I did address that in my response as well.