Unable to edit wpress divi theme after activating cloudflare ssl

Hi, I switched nameservers to cloudflare, then activated the free SSL on my wordpress site, all ok except when i login im unable to edit the content on Divi theme. I click edit and the divi builder content editor is not opening, it just hangs there loading. also some images were not displaying so i used the find & replace plugin to change http to https. on the last website I manually changed the wordpress address & site url to https and the site went offline saying redirect loop so I guess i should not touch that after the cloudflare is active.
pls advise, thanks.

Can you open F12 Developer Tools in your browser, then go to Console tab and see what errors are displayed in the console?

Hi there, it says:
load-scripts.php?c=1&load[chunk_0]=jquery-core,utils,jquery-ui-core,jquery-ui-widget,moxiejs,plupload,jquery-ui-tabs,jquery-form&ver=5.5.3:4 Mixed Content: The page at β€˜https://www.tribalfusion.asia/wp-admin/post.php?post=5&action=edit’ was loaded over HTTPS, but requested an insecure image β€˜http://www.tribalfusion.asia/wp-content/themes/Divi/core/admin/images/ajax-loader.gif’. This content should also be served over HTTPS.
attr @ load-scripts.php?c=1&load[chunk_0]=jquery-core,utils,jquery-ui-core,jquery-ui-widget,moxiejs,plupload,jquery-ui-tabs,jquery-form&ver=5.5.3:4
post.php?post=5&action=edit:1 Mixed Content: The page at β€˜https://www.tribalfusion.asia/wp-admin/post.php?post=5&action=edit’ was loaded over HTTPS, but requested an insecure image β€˜http://www.tribalfusion.asia/wp-includes/js/thickbox/loadingAnimation.gif’. This content should also be served over HTTPS.
Mixed Content: The page at β€˜https://www.tribalfusion.asia/wp-admin/post.php?post=5&action=edit’ was loaded over HTTPS, but requested an insecure frame β€˜http://www.tribalfusion.asia/?et_fb=1&et_bfb=1&PageSpeed=off’. This request has been blocked; the content must be served over HTTPS.
util.js:229 Google Maps JavaScript API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys
Qz.o @ util.js:229
util.js:229 Google Maps JavaScript API warning: InvalidKey https://developers.google.com/maps/documentation/javascript/error-messages#invalid-key
Qz.o @ util.js:229
DevTools failed to load SourceMap: Could not load content for https://www.tribalfusion.asia/wp-content/themes/Divi/includes/builder/scripts/page-settings-metabox.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
DevTools failed to load SourceMap: Could not load content for https://www.tribalfusion.asia/wp-content/themes/Divi/includes/builder/scripts/bfb_admin_script.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

pls advise, thanks, Jon

It appears this is the problem. Your site needs to have been working with SSL before you add it to Cloudflare. And now you’re getting Mixed Content errors because of this.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.