Unable to disable email routing DNS locking

When I try to change my domain MX record, it prompts that This record was generated by Cloudflare. It can be removed by disabling Email Routing on your domain, and when I go to Email > Email Routing > Settings page to disable it, it says Disabling, and it doesn’t work for me to repeatedly click the Disabling button.

I did the same thing for another domain and was go to Unlock records and continue/ Delete and Disable selection page, this one does not.

Please help me, I’d appreciate it.


Sometimes it may caused by a glitch, so I suggest you to clear your browser cache or using a different browser/ incognito mode, before trying to disable it again.

1 Like

Thank you for your reply.

I have tried these operations through different browsers and different network conditions, but this still does not work.

I’m confident that the environment I’m operating in is not the cause of this issue because I can successfully disable my other domains in the same environment.

One thing I believe is necessary to inform you.

For the domain that cannot be disabled, the MX record auto-added by Cloudflare is like:

MX	example_a.com	47	isaac.mx.cloudflare.net	Added
MX	example_a.com	8	linda.mx.cloudflare.net	Added
MX	example_a.com	4	amir.mx.cloudflare.net	Added

The MX record for my other domain is like:

MX	example_b.com	67	route1.mx.cloudflare.net	Added
MX	example_b.com	43	route2.mx.cloudflare.net	Added
MX	example_b.com	40	route3.mx.cloudflare.net	Added

I believe this difference is due to enabling Email Routing at different times. I’m not sure if this is relevant to the question at hand.