Unable to disable Cache

Hi
It looks like Cloudflare is caching php errors we temporarily got on our website.
We tried to purge all cache and create a page rule with “bypass” cache level for the whole website; still we see an error in home page, which does not appear if we add get parameters to the url (e.g.,/?1234), see attached pic.

Can you please help us understand how to reset our cache database completely?

Thank you,
Tommaso

Have you tried in an incognito window or clear your cache in the brower?

1 Like

Yes, clearing cache doesn’t work.

The response when curling the url you had in the screenshot is:

> curl -svo /dev/null https://www.auto-noproblem.com/ 

< HTTP/2 200 
< date: Tue, 14 Nov 2023 08:53:05 GMT
< content-type: text/html; charset=UTF-8
< vary: Accept-Encoding
< vary: Accept-Encoding,User-Agent
< set-cookie: PHPSESSID=939de88ab70da92b1bb8eb1c9b5c1948; path=/
< expires: Thu, 19 Nov 1981 08:52:00 GMT
< cache-control: no-store, no-cache, must-revalidate
< pragma: no-cache
< x-httpd-modphp: 1
< host-header: 6b7412fb82ca5edfd0917e3957f05d89
< x-proxy-cache: MISS
< x-proxy-cache-info: 0 NC:000000 UP:SKIP_CACHE_SET_COOKIE
< cf-cache-status: DYNAMIC
< report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=zzOHaiUJnWUAGKHHLm74q3JyZaBbTMUlgkKcRpjgKkVJZ1nWWX7palxhLTML0Wk8rRWdajJDrTbTj%2Fffx0zaoj4%2FKQ%2FQuKhgI630jLjeXTPirPqGS9ZUTJouQ6PmU%2B7AyAdSXnXW3tw%3D"}],"group":"cf-nel","max_age":604800}
< nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
< server: cloudflare
< cf-ray: 825e05a23d2a33f5-YUL

Given cf-cache-status: DYNAMIC , it means the response is not cached

Also without a query string, I get the same error and when I add a query string, I don’t so looks like some issue with the website itself that happens on the main page without a query string

1 Like

Hi team,

Cf-Cache-Status header is always visible and set to DYNAMIC.

We tried to purge cache and use developer mode, bust still the error is present if no additional URL GET parameter is added.

We also tried to use page rules with no success.

You can find attached the HAR file.

Could you please advise how to move forward?

Thanks

Tommaso

(Attachment www.auto-noproblem.com.har is missing)

Hi team,

Cf-Cache-Status header is always visible and set to DYNAMIC.

We tried to purge cache and use developer mode, bust still the error is present if no additional URL GET parameter is added.

We also tried to use page rules with no success.

Could you please advise how to move forward?

Thanks

Hi,

Cf-Cache-Status header is always visible and set to DYNAMIC.

We tried to purge cache and use developer mode, bust still the error is present if no additional URL GET parameter is added.

We also tried to use page rules with no success.

Could you please advise how to move forward?

Thanks

This means the response was NOT cached and is being returned by the origin server. This isn’t a Cloudflare caching issue,

1 Like

Thanks @cscharff for the reply.
Regardless the Cf-Cache-Status header, the problem still persist on my website on Chrome. I have also deeply cleared my chrome cache and reinstalled Chrome completely. On Cloudflare I also set a specific Page Rule to bypass cache in home page (see attached screenshot).

Ultimately, I also tried to PAUSE Cloudflare on the website and the error properly disappear.
This should evidence that Cloudflare is still caching an old error on Chrome.

Does anyone know how to manage this?

Can someone help us?

Please is urgent.

Can someone help us?

Please is urgent.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.