Unable to Delete Workers for Past Two Days

I’ve been unable to delete Workers from the dashboard for the past two days.

First I tried to do it using the “Manage Service” option and get this error:

image

image

Then I tried from the workers “settings” tab, but the worker can also not be deleted from here because it complains that you must first set another environment as default, but there always has to be an environment so it’s impossible to delete a worker from there.

Hey, this is a known issue currently. It was caused by the move to services. The team is working on it :slight_smile:

3 Likes

Ok thanks, but they need to work faster because this isn’t a trivial matter.

Two days is ridiculous.

When I use API to delete the workers script, it still displays. When I click, an error will appear
Not the expected result, A little bad experience

I am also not able to delete worker services, i was testing and got error 405:
API Request Failed: DELETE /api/v4/accounts/[redacted]/workers/services/default (405)

Tried:

  • Created another service and tried the delete it
  • Tried to logout, clean browser completely, and login
  • Another internet connection
1 Like

I have the same issue, I’ve tried to delete my workers (that I created accidentally) for the past 2 days and I am met with either a 403 or 405 error!

1 Like

I have quite a few test workers as I am learning and playing.

I would like to clean up and get rid of some of these but when I try to delete them I always get some error and it won’t work.

To delete I am going to the “manage service” link once I click into the worker.

Then I go to delete button… type in the name… and bam… error.

Just now I got this error…

“We could not find that Workers Service on your account.”

Is there another way to delete workers? I seems wrangler can’t do it.

1 Like

Sorry didn’t see this thread. Thanks for working on this!

2 Likes

When I tried deleting a service I used for testing (the “my-worker” example, to be exact), the system did not allow me to do so.

[ What I did ]

  • Login Cloudflare
  • Click on “Workers → Overview” on the left hand side menu
  • Click on “my-worker” in the main screen
  • Click on the “Manage Service” link on the top right corner
  • Click on the “Delete” button at the bottom of the screen
  • Enter “my-worker” to confirm, and click on the “Delete” button

[ Result ]
The following message appear at the bottom of the screen with RED background:

API Request Failed: DELETE /api/v4/accounts/xxxxxxxx/workers/services/my-worker (405)

where xxxxxxxx is my Account ID.

I think I should contact technical support for matters like this, but since I am currently using the free plan, the help system suggested me to ask the question here.

FYI, I changed my subdomain name once, after creating the service, in case this matters. Now, I am unable to delete or rename the “my-worker” service under my “workers.dev” subdomain.

Any help would be appreciated! Thanks!

1 Like

I’m seeing the same problem, unable to delete a worker, different error message though:

We could not find that Workers Service on your account. (Code: 10090)

1 Like

Yes, you see this because Cloudflare is fixing the problem. Please take a look at this:

1 Like

Something has changed and the error code is different now, but you still can’t delete the worker service when there’s only a single environment.

image

However, if you create a second environment and then try deleting again under “Manage Service” you can now delete the worker.

Using this method an error is displayed but the worker does appear to be gone.

??

Ya, i am getting same if there was change how to now? Better if cloudflare to tell us what that is change…release notes i am missing??

Just to reiterate what I said earlier:

Team is working on it and I will update here when it’s fixed!

3 Likes

Hey everyone,

Delete should now work as expected! You may see a red banner at the bottom when loading the list, this is also being fixed right now.

Sorry for the inconvenience there!

3 Likes

Confirmed, can now delete workers without having to create a 2nd environment.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.