Unable to create workers usage notification - no support response!

Hello, I am unable to create a billing notification for workers. It does not appear in the drop down.

I have created two support tickets for this since almost two weeks ago, both of which have received no response. What is going on?


1 Like

checking. Thanks for tagging

What plan do you have for Workers? I believe these notification options are based on the subscriptions on your account. It would not surprise me, for example, if you could not create a billing notification for a product on a Free subscription. The option only appears for me where I have a paid Workers subsctiption that is usage based.

It’s set to use the paid plan, and the worker was created with wrangler. Maybe it broke because I didn’t use the dashboard to create it?

Can you check what shows for Workers in the Billing → Subscriptions page on your dashboard.

Interestingly, the dashboard actually suggests to create the notification ever since the worker was made, but it doesn’t appear in the drop down when I go to do that.

Seems fine there.

1 Like

Oh, the entire usage based billing notifications show as only available on Pro or above here:

That seems odd to me but do you have any Pro zones?

Yeah, the domain the worker is running under is on the Pro plan.

1 Like

This is what “kian” on the Discord showed me the option should look like, if it existed, above the Durable Object stuff. But my list doesn’t have this entry for some reason.

It appears here in the list for me, do you have anything above the DO ones?

Nope, those are the start of the list.

Did you check this

Sometimes this page is actually bugged even more, and only shows the Durable Object entries. Refreshing makes the rest appear, but no Workers.

1 Like

I’ve enabled the Workers Usage Report, but it’s a separate thing, there should also be an entry for workers under Usage Based Billing.

At least, multiple people have shown me they have one - see the images further up in this thread
For some reason I don’t have that entry.


Got it checking with the team internally and will get back to you

1 Like


Hi Anjana - here’s what it should look like, at least on all of my accounts:

1 Like

Got it. I am reaching out to the team to see if we can escalate this internally


So today I checked again and it seems we’ve made progress. The option now exists!

However, trying to set up the notification with it doesn’t work: