Unable to create subdomain

I’m using Cloudflare (free) to manage my DNS for my own domain, monologue.ie. I have a number of subdomains setup on this already, which were created with no issues. I am not trying to create ‘cdn.monologue.ie’ but it’s failing every time. I have spoken to my hosting company and they seem to think it’s something to do with Cloudflare. I have attached a screenshot of the error I’m getting.

I had initially created a new site/domain for ‘cdn.monologue.ie’ before I realised that I could create it as an alias on my existing domain. So I deleted my extra site/domain ‘cdn.monologue.ie’ and then tried to add this as an alias to my main domain. I also recently updated my email address associated with Cloudflare. I’m guessing my issue has something to do with both of these things.

Can anyone offer any solution to this?

Thanks,
Michel.
Screenshot 2022-02-20 at 11.04.22

Greetings,

Thank you for asking.

From the screenshot, the error suggest e-mail used for the POST request is not correct.
And you state you changed your e-mail, but did you changed the “email value” when sending the request? :thinking:

Nevetheless, maybe the Global API key changed in the meantime while you changed your e-mail? Otherwise, you might be using API Token instead of Global API Key?

So you’ve want to create an individual DNS record (for sub-domain)?
It can be created with this API call:

curl -X POST "https://api.cloudflare.com/client/v4/zones/YOUR_ZONE_ID_HERE/dns_records" \
     -H "X-Auth-Email: YOUR_CF_ACCOUNT_EMAIL_HERE" \
     -H "X-Auth-Key: YOUR_GLOBAL_API_KEY_HERE" \
     -H "Content-Type: application/json" \
     --data '{"type":"A","name":"sub.yourdomain.com","content":"192.0.2.1","ttl":3600,"priority":10,"proxied":true}'

Source article:

May I ask you to share or re-check the API request which you were sending?
If you share it, please mask/hide (redact) your data due to security & privacy concerns.

Have you used cURL or Postman app or some integration like with PHP code, etc.? :thinking:

Hi Fritex,

Thank you for your reply. How/where can I find my API request being sent? I am using Gridpane to administer my servers and the new subdomain/alias is being created via Gridpane.

Thanks,
M.

I just checked in my GP account and my old email was indeed still in the API credentials. Now, I’m told that if I change this I may experience some SSL isues with my sites. I manage a number of sites for clients so I can’t really have any downtime. What’s the best way forward in this situation?

I am unfamiliar with this and don’t know how it works :frowning:

Right, here is the issue then as far as Gridpane uses old email which isn’t anymore related to your CF account.

May I ask how do the other domains work then via Gridpane, if so? :thinking:
Don’t they already have an issue, even after you changed your e-mail?
Have you tried sending some request already for them?
Does it work or throws the same error?

Why would you have some at all? :thinking:
Don’t they run over HTTPS already?
Try out.
If you get some error, post domain name here and/or share error number so we could troubleshoot and resolve it.


When I go to change the email address I get this message in GP.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.