Unable to connect to server

I give up. Been trying since yesterday evening to use a domain to access my home server.

Before I signed up with cloudflare, I was using Godaddy. I had a Dynamic DNS and it worked as you would expect. typing in my domain dwperk.com would send me to my router’s login page as I did not have a webserver configured yet.

So my next step is to create a reverse proxy. And it was recommended that I use cloudflare because it was easier than godday to make dns changes and was more secure. OK, created an account, changed the nameservers on my domain, and walla, dns records appear in cloudflare. pinged the domain and I get cloudflare IP because dns was proxied. Expected result. enter domain into browser, get to my routers login page. woohoo!

So I proceed with next steps
Created a dynamic DNS to point to cloud flare. log say its it working.
used a docker container (swag) containing letsencrypt and nginx. Created the port forwarding on my router, changed the necessary config files for nextcloud. Created a new cname in cloudflare and proceed to test my work. entering cloud.dwperk.com, returns ‘Site cannot be reached’. So I try www.dwperk.com, same error.

OK, so I ping cloud.dwperk.com & www.dwperk.com, and they resolved back to the cloudflare ip. I then changed the dns records from Proxied to DNS only. www.dwperk.com works, but not cloud.dwperk.com.

Thinking I did something wrong along the way, I undo everything including removing the port forwarding in my router. OK, pinging still good, but entering the domain in the browser is getting mixed results. sometimes it works, sometimes it doesn’t. Same is true with entering the IP address.

so I setup the webserver, forward the ports in my router and put in a generic index.html and I can see the page in browser from 3 different devices. one is my personal laptop on my home network using chrome incognito mode. The other is a work laptop using a vpn to the office, but on my network, using ie. The 3rd is my phone with wifi turned off.

I get ready to start adding subdomains and configuring apps. each small step along the way, I would keep trying to access dwperk.com. It worked sporadically but mostly I would get failures. ‘This site can’t be reached’ ‘No data transferred’, or the Cloudflare page showing that it all works on their end except at the server.

At this point it, it is a complete failure, nothing works. even typing the ip address doesn’t work. Every docker that was modified for this process has been removed and all related files were deleted through linux using the ‘rm -r’ command. So there shouldn’t be any residual config file somewhere hosing me up.

The only change ever made in the router was to forward the http and https ports. They are removed. So I should be seeing my routers login page. But I do not. Pinging still resolves.

The only thing left for me to try is to create a time machine and stay with godaddy. Which I think might be easier. Time for someone smarter than me to give me things to check.

I’m just looking at dwperk since ‘www’ is a CNAME for that. Right now, dwperk is DNS only, so it points straight at an IP address that belongs to Verizion FIOS. I guess that’s what you want.

Except that it’s refusing connections on Port 80, which isn’t a surprise since most Internet providers don’t want you running web servers inside your network.

A better approach would be to create a Cloudflare Tunnel on your server so don’t have to worry about the port limitations of your ISP.

https://developers.cloudflare.com/cloudflare-one/connections/connect-apps

If they were just blocking http and https, would having a port forwarded work? Say dwperk.com:12345 would forward to my router’s login. Because I can’t get that to work either.

As your DNS record is DNS Only, this has nothing to do with Cloudflare. It’s a direct connection to your IP address.

For starters, see if making connections using your IP address instead of the hostname work.

I have, it is not working anymore.

So you are saying it is just a coincidence that it worked for 2 weeks while I was on godaddy and the hour I change it to cloudflare, my isp is now blocking incoming traffic of any kind?

Seems so:

Are you sure your IP address hasn’t changed?

It has been the same since I purchased the domain a couple of weeks ago. My wan IP is a public IP.

Am I right in understanding that your cloudflared product is just a vpn?

It’s similar. It’s a tunnel, like some people use SSH as a tunnel. It’s two very specific endpoints: The server, and a Hostname (CNAME). Or more hostnames if you’ve configured it to tunnel multiple hostnames.

I am afraid I have to agree with you. I haven’t setup my log to save for long periods so I only have the last couple of hours. Despite my repeated attempts to hit port 80, there is no traffic coming through my router.

Fios support are insisting that they do not block any ports on there business internet product. But now, it looks like I can show proof that port 80 is not getting to my router.

Thanks for your help.

1 Like

HI
after working with my ISP. ports 80 and 443 are open again.

Few a few tries, I was able to connect by typing in the IP address. But typing in the domain still wasn’t working. Now I can’t get the IP address to work anymore.

Pinging still resolves. Going bald pulling my hair out

Again, that’s something you have to take care of with your ISP.

But the ip address was working at the same time the domain name wasn’t.

Anyway, I think I figured it out. I have to type https://dwperk and it works. Something I didn’t have to do with godaddy.
You wouldn’t happen to know how to make it work without having to type https:// 1st?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.