Unable to connect the certificate with my cpanel

every time i enter the certificate to my cpanel
this message appears
“The certificate uploaded is NOT for the domain name inkohost.com (CloudFlare Origin Certificate was seen) .”

though my domain is already connected with cloudflare and been accpeted

May I ask if you manually connect / added your domain to your Cloudflare account, or by using cPanel “Cloudflare” feature? (some providers still have got it)

I see I got 525: SSL Handshake error returned when I visit your Website.

Furthermore, doesn’t the cPanel offer AutoSSL?

Nevertheless, if you went up by using Cloudflare Origin CA Certificate, just keep in mind you cannot use it for your e-mail and sending/receiving your e-mails would result in errors (despite having your A mail record set to :grey. (DNS-only)).

  • It can be used only for the Web traffic and any proxied :orange: hostname (DNS record) at Cloudflare dashboard.

In case you will not use e-mail, you are good to go with Cloudflare Origin CA certificate on cPanel.

  • I forgot to mention, may I ask if you used wildcard * (apex symbol) for sub-domains (added by default within your naked domain) when creating an Origin CA Certificate or not?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

Kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

May I ask have you got any HTTP to HTTPS redirection set on your cPanel web hosting?

How about the options at Cloudflare dashboard under the SSL/TLS tab → Edge certificates:

  1. Always Use HTTPS
  2. Automatic HTTPS Rewrites

Are they enabled (on) or disabled (off)?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.