Unable to connect RDP via Local Network

I am following this guide to setup Warp for RDP,


I have onboarded the server tunnel and setup policy for Client Onboarding, The client PCs successfully connects to zero trust organization, however they are not able to access the RDP via private IP, My server has a static Public IP currently being used and private IP, I have added the following Private Network CIDR Block (which is the Private IP of my Server)

These are my server network Settings

Can someone guide me what I am missing here?



You should exclude ip to the warp.