Unable to connect bucket using S3FS

I’m running Debian VPS and attempted to connect R2 bucket using S3FS package.
No connection was established and errors 3575 & 3597 were returned

What is the correct syntax to connect to R2 bucket?
The r2pwd file was created using echo R2-AccessID:R2-Secret, values created in Cloudflare via API Token creation and file access right set via chmod 600

My command is as follow and received error…

s3fs -o passwd_file=~/.r2pwd -o url=‘https://{R2-Account ID}.r2.cloudflarestorage.com’ -o use_path_request_style -o endpoint=auto r2bucket /mnt/bucket

Oct 18 08:15:53 d31 s3fs[1604]: s3fs version 1.90(unknown) : s3fs -o passwd_file=/root/.r2Pwd -o url=https://{R2-Account ID}.r2.cloudflarestorage.com

Oct 18 08:15:53 d31 s3fs[1604]: Loaded mime information from /etc/mime.types
Oct 18 08:15:53 d31 s3fs[1605]: init v1.90(commit:unknown) with GnuTLS(gcrypt)
Oct 18 08:15:53 d31 s3fs[1605]: s3fs.cpp:s3fs_check_service(3575): Failed to connect by sigv4, so retry to connect by signature version 2.
Oct 18 08:15:53 d31 s3fs[1605]: s3fs.cpp:s3fs_check_service(3597): unable to connect(host=https://{R2-Account ID}.r2.cloudflarestorage.com) - result of checking service.
Oct 18 08:15:53 d31 systemd[1]: mnt-bucket.mount: Deactivated successfully.

The problem you’re encountering is likely linked to the recent implementation of “virtual-host paths” in Cloudflare R2 Storage. To resolve this, ensure that you are using the most up-to-date version of the S3FS package, as it should support this format.

Additionally, there appears to be a potential issue with your command syntax. Your command should adhere to the following structure:

s3fs {bucketName} {mountPoint} -o passwd_file={passwdFilePath} -o url=https://{R2-Account ID}.r2.cloudflarestorage.com -o use_path_request_style,url=https://{R2 Account ID}.r2.cloudflarestorage.com

Simply replace {bucketName}, {mountPoint}, and {passwdFilePath} with the accurate information. Be sure to confirm that {R2-Account ID} and {bucketName} are correctly specified as well.

Thanks for the reply, I’ve tried to no avail, I still get the same error
The s3fs version used was 1.90-1.

Is there any additional ports that is required at the firewall?
Currently the setup only allows http and https traffic.