Unable to change Name Servers

Hi. I am trying to set Cloudflare on my website cambiovitausa.it but I am unable to. Every time I change the DNS with my registrar (GoDaddy) it says “pending” for 5 days and then the DNS revert back to normal. My registrar says that the nameservers that Cloudflare gave me are not authoritative (addilyn.ns.cloudflare.com and remy.ns.cloudflare.com).

When I use this tool https://dns-check.nic.it/ I get this error in the screenshot below.

I’ve used the search button and this post was the closest to my issue but still unhelpful. DNS CNAMEHostTest Failed Unable to transfer zones

How can I resolve this? Thanks in advance.

It actually is not unhelpful :wink: as it describes exactly your issue.

Just like in all other cases you’ll also have to convince one of the three parties (registry, registrar, Cloudflare) to force the new nameservers. Whom you pick is up to you :slight_smile:

I’m trying with all three parties without success. Godaddy says they can’t. Cloudflare hasn’t responded to a ticket in over a week and still waiting from nic.it.

How long does it usually take to resolve a ticket with Cloudflare? (Free plan).

Thank you Sandro.

The free plans are the very last in the priority queue. It can take a few days I am afraid. Can you post the ticket number?

Why Godaddy? Isnt 1Api you registrar?

The other thing you could try is to drop the domain from the other Cloudflare account. That could take some time but eventually Cloudflare should stop announcing the other nameservers.

My ticket number is 1840686. That’s the ticket where I asked to purge my zone to speed up the process (if that’s the issue).

As I didn’t get an answer in 9 days I thought that CloudFlare just didn’t accept my request so I opened another ticket where I explain the issue more in general (1844815).

And my registrar is GoDaddy. I don’t know why it shows 1Api. I am located in the US so I need a trust service to have a .it domain. I guess that’s what GoDaddy uses.

Also, I dropped my other CF account already.

EDIT: nic.it told me that CNAME’s aren’t allowed in .it domains. So I deleted all my CNAME’s but still same error in the original post.

Then Godaddy appears to be reselling, as they are not listed as registrar. Or they own that registrar.

I am not sure what they meant. This is not a CNAME related issue.

If your registrar says they cant and the registry refuses, your only option is to go via Cloudflare or to drop the domain from the old account.

When did you drop the domain from the other account? Did you make sure you replied to any automated emails you got from Cloudflare? Otherwise the ticket might have been automatically closed.

@cloonan

I dropped the old account a couple of weeks ago. And yes, I responded to both automated answers to my ticket.

I told the registry that and they gave me a very non-responsive vague answer:

"…the checks carried out by the .IT Registry relating to the MX record:

Check that the nameservers in the SOA, NS and MX records, if any, are not CNAMEs:

  • a CNAME cannot be associated with the MX record, if any;

If the MX record is not present you must associate an A record for the domain
Cambiovitausa.it IN A <IP_address>

You can check and test the configuration on our tool
https://dns-check.nic.it

If it is OK, the verification will be automatically tested by our systems, consider a maximum of 2 hours for updating our DNS."

Alright, the nameserver issue appears to be resolved.

As for the MX record, you do have an MX record set which points to cambiovitausa.it however there is no respective A record for your naked domain. Add that and it might just work.

There is already an A record that points to the website’s IP but the test still fails. If I put the domain name with the www, the CNAMEHostTest on nic.it test succeds though. These are my MX and A records. Which ones should I change/add?


I’m a little late to the party, but I don’t see any DNS problems, other than it’s not using Cloudflare name servers.

I can’t see your screenshot!

At your current nameservers, not Cloudflare, and that is what is being tested. You need to fix your DNS configuration on Cloudflare. Add the A record for the naked domain there.

Got it. I added the A record on Cloudflare and the CNAMEHostTest on nic.it succeds! I updated the name servers now. I’ll let you know if it will go through.

It finally worked!!! Thank you Sandro. Not just for this solution, but for the immense support that you provide to this community.

2 Likes

Merci, @user6823 :bowing_man:t2:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.