Unable to cache site


#1

HI,

For some reason, cloudflare is not caching the JS and CSS file.

In the response header, we kept seeing the status as cf-cache-status:

MISS

Link to the website below:


#2

Caches it for me

image

How many times did you request the file? Whats the output of https://www.tailor-m.com/cdn-cgi/trace


#3

I tried on a different network and still getting the MISS.

The output is:

fl=19f62
h=www.tailor-m.com
ip=46.233.78.148
ts=1538315338.047
visit_scheme=https
uag=Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/12.0 Safari/605.1.15
colo=CDG
spdy=h2
http=h2
loc=GB
tls=TLSv1.2
sni=plaintext


#4

Not sure if this is expected behaviour, but I opened console and disabled cache, then enabled again and now its a HIT.

Something I noticed though after enabling cloudflare is the request header comes up with a “Provisional header”, please see below. Is this something to be concerned about?


#5

I asked before and just to be sure, these were not first-time requests but followed earlier requests for the same resource, right?

If you now get a HIT I’d assume it was simply not cached earlier. Could it be you send any directives which could prohibit from doing so? However, as mentioned initially, I do get cache hits.


#6

Sometimes it just takes several requests before all the Edge servers at that datacenter have your data in cache.


#7

This topic was automatically closed after 14 days. New replies are no longer allowed.