Unable to add new or modify existing Cloudflare apps to my sites


I wanted to try to modify an existing app on my site (absurdaf.com). Initially, it was Particles. When that failed, I tried to do the same with the Add HTML app. Same result. Then I tried Corner Ribbon. No dice.

I keep getting the same error message when I attempt to install a new app or edit an existing app. The error message reads as follows:

" An error occured loading this page. Please double check the URL. If it continues to fail, please try again later or for assistance."

I have been able to install, edit and uninstall apps in the past. I’m not sure what has changed. The good thing is, existing installations don’t appear to be affected (they work). I have multiple sites with the same apps installed and would like to modify some (like I used to be able to do), if possible. I have encountered the same issue with other Cloudflare domains.

When I click on the support link that’s provided, I get another message.

Any ideas on how I can resolve this?

1 Like

Did anything about your browser change? Extensions?

Could it have been just a temporary issue? Have you tried again meanwhile?

If it still doesnt work I’d suggest to open a support ticket.

1 Like

We have the same problem

1 Like


Appreciate the response, and those are all great questions.

To rule out the issue of a potential conflicting extension (I know I’ve added several since I started adding and modifying apps over the years), I tried using multiple browsers in normal and private/incognito modes with no extensions.

The result was the same, unfortunately. This has only been happening recently. But I can’t modify, add or even delete apps on any of my Cloudflare sites.

This has been happening ever since Nov 23-24. It could be temporary, but as of the last 24 hours, it’s still an issue.

I ultimately opened a ticket, and I was told that the apps team would be running diagnostics and would hopefully provide a resolution for this issue.

If you post the ticket number here, @cloonan can track it too.

1 Like

The ticket number is 1793105.

Thank you, I see your ticket and the escalation, I’ll keep an eye on progress. Sorry for the issues & thank you for reporting it!

1 Like

A quick update:

It appears that the issue has been resolved. If I run into any more problems, I’ll let you know. Hopefully the issue has been resolved for anyone else who may have been impacted in the same way (including @valentin.david).

The only app that fails to work is Particles (but it doesn’t give an error message). I have reported that in the past, and I’ll try reporting it one more time (if it doesn’t work, I can add manually).


1 Like

Unfortunately, the Particles app is still an issue. I’ll do what I can to add that manually.

Thanks for looking into this.

Happening again, but on a different site. Weird, because it works for the majority of my Cloudflare sites. Any help to resolve would be greatly appreciated.

Support ticket is 1967731.

Thanks in advance!

It may be related to this, though it does say it’s been resolved:

1 Like

I’m not 100% sure if it was related to that, as I did some tweaking here and there, as well. I’ll say it was 50/50, lol. I appreciate your response.

Issue resolved (again!)


1 Like

I’m having the same issues with all apps. Adding new apps and previewing them has never worked. Please help!

@jatingupta69 I’m having the same issues with all apps. Adding new apps and previewing them has never worked. Please help!

Ticket #: #2022531

Hi @user8424,

Assuming the app isn’t outdated (which is what ultimately happened to particles), try lowering your TLS setting on the site(s) you’re attempting to install/preview the apps. I think that helped me a few times. If it is already at 1.0, then I’m not sure what the issue could be.

Good luck!

1 Like