Unable to add new domain with TLD .cyou bought from sav.com

My issue is as the title says:
I have read all the information and troubleshooting regarding this problem.
I have also tried using the dig command. dig jassy.cyou @, and all the added DNS shows up including the nameservers.

After browsing similar issues like #331607 , I have confirmed this issue is Cloudflare side and not sav because I have already tested this domain by adding it in desecio and also tried adding to Cloudflare later.

What is the exact error message you get when attempting to add the domain to your Cloudflare account? How long ago did you register this domain? It’s possible that it may take a few hours for it to be usable.

The error was " jassy.cyou is not a registered domain" and after contacting here the new error is “This web property is temporarily restricted from being added to Cloudflare at this time. Please try again later, or contact Cloudflare Support with any questions.”

PS: I have bought this domain a few couple of hours ago.
The recent error is 1105 that is because of me getting rate limited for trying to add this domain again and again.
Please I request you to help me for the former issue " jassy.cyou is not a registered domain"