Unable to add DKIM record for Hubspot

Hello,

My organisation uses Hubspot and I am trying to add a DKIM CNAME record for my email sending domain.

Hubspot is unable to detect this record.

One thing I noticed: the target provided by hubspot is:
winki-com-au.hs04a.dkim.hubspotemail.net.’
But when I enter it into Cloudflare, the dot at the end is removed automatically. Not sure if that is relevant.

I have spoken to Hubspot support and they suggested engaging the cloudflare community. I’m sure others will have found a way around this issue. Thanks in advance for any assistance.

Since we’re having a combination of DKIM and CNAME here, …

Make sure the Proxy status for this CNAME record is set to Unproxied (:grey:) / DNS-only, and NOT Proxied (:orange:).

If that doesn’t help, please provide the DKIM selector, alternatively the full name of the record (e.g. “example._domainkey”).

1 Like

Thank you for the quick reply.

I had already turned it to unproxied to no avail.

As requested, the record name is: hs1-45003193._domainkey

You haven’t, though. It is very much still proxied right now.

1 Like

Oh really? I thought this would mean it is turned off:

What am I doing wrong?

Statistically, you probably are in the wrong account. Can you verify that the nameservers assigned in that account (on that DNS page) are named jocelyn and mitchell?

UPDATE:
I do not see any additional nameservers assigned to your domain.
https://cf.sjr.org.uk/tools/check?984c8a48e5a34cd2a249114cc99eeaf4#dns

I also found no delegation to other nameservers for _domainkey, which is good.

Can you delete the CNAME and try creating it again with the following:

Name Type Value Proxy Status
hs1-45003193._domainkey CNAME winki-com-au.hs04a.dkim.hubspotemail.net. :grey:

Don’t worry about the trailing dot disappearing after you save it. That is normal.

1 Like

You were correct! I was in the wrong domain.

Thank you for your time and your help. Greatly appreciated!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.