Unable to add DKIM for Gsuite

I have followed the Google Suite instructions to created DKIM for my domain reservations.express. I have created TXT record in account ggle._domainkey with the key (v=DKIM1; k=rsa; p=…).

However when I check for key with Google Suite Toolbox SPF checks out (with same implementation) but DKIM is not detected. When I check with MXToolbox (dkim:reservations.express), all I get is “An error has occurred with your lookup. Please try again.”

nslookup -q=TXT ggle._domainkey.reservations.express 8.8.8.8 shows the correct key

What am I missing?

Did you change the default domain subdomain? Why isn’t it the normal google._domainkey.reservations.express?

I first tried google._domainkey.reservations.express, did not work… I’ve just changed it to ggle. to see if it changes anything…

Did you change it in the G Suite settings, though?

Yes. google._domainkey did not work. So I generated a new key ggle._domainkey and added to cloudflare.

I feel like there is an error somewhere in the copying. Can you post a screenshot of the G Suite DKIM page?

GSuite:

Cloudflare:

Windows:

MXToolbox:
image

I have a doubt that something is wrong with the actual domain support for that TLD… I would write to G Suite support.

  1. That tool you’re using to check it is broken; it’s giving the same error even for domains I know to be valid.
  2. You copied a line break into the Content field for the TXT record. You need to remove the line break between / and A.

Mine shows the same break, it’s correctly copied in the dashboard. It’s just visualization in the DNS reply.

1 Like

Ah, you’re right. @erix, I think your record is just fine; sometimes it just takes Google a while to get a new result.

2 Likes

Thanks guys…

I changed the key because it was fine last week, but this week new emails started landing in spam folder.

I will contact Google about it.

P.S. Can more than one DKIM, on same domain, cause an error?

As long as they use different IDs (the part before _domainkey), you can have multiple.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.