Unable to add custom domain "Please enter a valid domain"

hi i just created cloudflare page, here is the link neko-kids.pages.dev , but when i want to add custom domain it shows like this :

when i create it using cloudflare worker site , i can add custom domain with same domain name in cloudflare pages

this looks quite weird, i want to use cloudflare pages instead of having to deploy it on cloudflare workers, if possible i want to remove the website from workers and move it on cloudflare pages.


I have a suspicion about what the issue is, will investigate more on Monday and get a fix out.


hi, thanks for the reply, I’ve tried it and it still doesn’t work, are you still fixing it

It’s not yet Monday in all time zones in the US and it is not working hours in any of them, nor the UK or Europe. Give it some time. I expect that you will see a reply here when there is news to report


Fix is ready, I’m trying to get it live as soon as I can

You can use the API for now, this error is purely client side, the API knows it’s valid.


I’m very grateful, but I’m still a beginner, can you tell me how to use the API to add the custom domain🙏

Fix is now live, you can use the UI (make sure to refresh) :slight_smile:


thanks I can add a custom domain now🙏

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.