Unable to add .com.pk domain in Cloudflare [Solved]

Hello,
I am unable to add my .com.pk domain in cloudflare. I am getting an error that domain is not registered. However, my domain has been registered by PKNIC.
What should I do?

What did the search here on the forum say about the error message?

Multiple users are facing this issue. I have tried those solutions but didn’t worked.

So Search results for '"not a registered domain"' - Cloudflare Community didn’t give you anything?

What’s the domain?

They didn’t worked for me

Strange, because the mentioned steps work in all cases.

edited

what might be the issue?

And so do in your case. The very first suggestion in the article already applies to your domain. You really need to read the articles carefully and follow their suggested advice.

I have added the DNS nameservers using dns.he.net

In that case you should contact your registrar, as no nameservers are being returned.

DNS Checker - DNS Check Propagation Tool

It will take 24 hours to reflect the changes of the nameserver.

Then you will need to wait that long.

ok I will update you after that

@sandro check now nameservers are showing

Well, and now it should work.

getting the same error. Now what to do?

There still seems to be a mismatch between what you configured and what your authoritative nameservers advertise. You should make sure that matches.

1 Like

How to check it?

You compare what you set to what you were given.