Unable To Add CNAME


I have just joined the community so please be gentle.

I am trying to add a CNAME record for a new sub domain but am getting the follow error:

DNS Validation Error (Code: 1004)

I have created the sub-domain on my host. Tried creating the CNAME their but was getting an error saying

“Error: subdomain.mydomain.com. already has a A record. You may not mix CNAME records with other records for the same name”

Sent Host Support a ticket and eventually realised that I am using Cloudflare, so said create the CNAME here but tried and cannot.

Any suggestions???

Many thanks

You already have an A record for „subdomain“. You need to delete it if you want to use a CNAME with this name.

Hi Mark,

Thanks for replying so quickly.

There are no A records in cloudflare, but there are 2 on my web host, but with slightly different names.

Which one do I delete? The first? Both?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.