Unable to add application to Access via Zero Trust Dashboard


I am trying to add a self-hosted application to the Access section of the Zero Trust Dashboard (top image).

After going through the “Add an application” wizard, I get a notification on the Zero Trust Dashboard in the top right corner claiming that the application was successfully configured (bottom image), but no applications appear in the list and I am redirected back to the original screen I was presented with (top image).

Troubleshooting so far

  • Tried refreshing and being patient in case it took a while for my application to appear in the list, but nothing ever appear.
  • It could be a browser issue, but I tried via multiple computers and browsers and had the same issue.
  • Perhaps the application access rules are being added successfully, as the notification suggests, but I can’t seem them (i.e. a GUI issue on the server end). To test this I added an application rule that should have prompted me for email verification upon accessing my service, but it did not. This suggests something else is going wrong and I am not getting an error message for it.

I’m facing the exact same problem.
In my case I already had 5 Applications configured, but can’t add another. Same behaviour as you. It goes through the wizard, all fine, click the last button, get the top-right success notification but no new Application on the list and no authentication request on access to the address, so all I can surmise is the configuration didn’t save and apply.
I can, however, edit and save changes to my existing Applications, so that part of the dashboard seemingly isn’t all broken.

Good news: about 12h ago I tried adding my Application once again and it worked.
Maybe some problem that got fixed or maintenance going on in the background that interfered with the process.
Either way, seems to be working as it should now.