Unable to activate SSL Certifiacte

My host provider is Hostupon, and I’ve been trying to install an SSL certificate but they told me I have to do it first with CloudFlare.
I have created a free SSL on CloudFlare, and I copied that into my server but it shows NOT VALID CERTIFICATE.
I talked to them again and they said that they cannot help me since the issue is with CloudFlare.
Is there anything else that needs to be done after creating to certificate?

Was it the Origin CA Certificate? Sometimes it needs the third part (Root CA) for it to validate. Step 4:

Thanks for the reply. The issue I am facing is configuring apache. I could not find httpd.conf and apache2 is not inside etc folder. Show hidden files is enabled.
I am on shared hosting.
I know this question is for Hostupon, but I think they hesitating to help.

If it’s shared hosting, I’m 99% sure you can’t do this in the server config files. It would have to be done through their customer interface.

1 Like