Unable to access Wordpress wp-admin - Error 500

wordpress

#1

Hi,
I’ve been using Cloudflare’s free plan for a while now and sadly I had to reinstall my whole site (https://boichi.com) as well as the server hosting it. (wiped the wrong server, oups)
The site is on wordpress and the server uses nginx.

I used a backup so the site is back online (with SSL working) but sadly I’m unable to access the back-office. wp-login.php works but wp-admin only shows an ERROR 500.
I’m using Cloudflare’s plugin to fix the common ERR_TOO_MANY_REDIRECTS.

While the backup brought back the site as if nothing happened, I still had to configure nginx myself. Last time I did it was over a year ago so I might have forgotten something this time around.

I’ve been looking on every community thread as well as other results around the web and nothing I found worked so here I am asking for a more case-specific help.

I have access to FTP, SSH and the Database
Thanks!


#2

Check wp_options, specifically option_name IN (‘siteurl’,‘home’) to verify you have the correct URL.


#3

it’s https, though I tried also tried to revert it back to http just in case
and yeah, the url is the right one


#4

Just for kicks, how about setting this in wp-config.php?
define(‘FORCE_SSL_ADMIN’, false);

Too many redirects usually happens when you have SSL set to flexible, but Wordpress is set to https.


#5

nope didn’t work.
I also tried playing with the page rules and the “always use https” setting before but without success


#6

when reloading the /wp-admin page on Chrome, the “securised” mention seems to flash before getting back to a broken https. the /wp-login.php page works normally and with SSL

it’s indeed most likely a redirect issue but how can I find where it comes from?
also, you say this usually happen with SSL set to flexible so maybe it could be fixed if I switch to Full?


#7

Full is only going to work if you have some sort of SSL certificate on your server. And if you can get an SSL cert on your server, then that’s the way to go, as Full is more secure than Flexible.


#8

yeah, I have full access to my server. I’ll try to get a custom cert from cloudflare and switch to Full


#9

This topic was automatically closed after 14 days. New replies are no longer allowed.